What is “VM Upload”?

1. “VM Upload” allows you to import your own VM and add it to your environment running on
CloudShare. This provides a convenient way to upload VMs and appliances which were already
built.

2. “VM Upload” provides you with the ability to share your externally configured VM with your
partners or customers as part of a fully configured environment.

How do I use “VM upload”?

You can either:

e add it to an environment you already have in CloudShare, or
e add it to a newly created environment

Pre-requisite - Preparing your VM for upload

The following describes the technical specifications and pre-requisites to create and package the VM
before you upload it using CloudShare’s “Upload VM” tool.

VM format

In order to upload a VM you need to have a VM image in one of the following formats:

e OVF - Complete VM package contains a minimum of three files: <vm_image>.ovf; <vm_image
disk#>.vmdk; <vm_image>.mf

e OVA-Single Tarball file of the VM image

e Zip (recommended) — Multi-part zip archive of the OVF file set or OVA (refer to Multi-part Zip
Archive)

Note: An OVF package contains one OVF descriptor (a file with extension “.ovf”) which is an XML file
that describes the packaged virtual machine. In addition, the OVF package will typically contain one
descriptor and one or more disk images (files with extension “.vmdk”) and a manifest file used for
integrity and authenticity checks (a file with extension “.mf”). You can learn more about OVF and OVA
formats here.

The above VM formats should have the following requirements:

1. Created by using VMware-based products (ESX, vCenter Server, Workstation, Fusion)
2. Your VM should use hardware version 4 through 9

Guest OS

1. Your guest OS should be one of the following:
a. Linux flavors: CentOS, Ubuntu, SUSE, Red Hat
b. Windows versions: XP (32-bit only), Server 2003 R2, Server 2008, Server 2008 R2 SP1,
Windows 7 SP1, Server 2012, Windows 8, Windows 8.1


http://en.wikipedia.org/wiki/Open_Virtualization_Format

Note: we do not test other operating systems, though they may also work. You should
thoroughly test the VM after the upload is completed.

2. Your VM CPU ID mask must not be set to use an AMD processor
3. VMware tools must be installed on your VM

Virtual Hardware Specification

1. CPU: VM may have up to 4 CPUs
Disks: VM must have at least 1 attached disk. The VM can include more than 1 disk but you will
not be able to change the disk size of the additional drives after uploading the VM to CloudShare
3. Network adapters: VM may have up to 10 network adapters
4. CPU, RAM, Disk size — Totals should not exceed your CloudShare hardware quota as agreed
upon in your contract

Additional requirements

The following requirements ensure higher performance and better compatibility when running on
CloudShare’s service:

Set screen resolution to 1024 x 768

Install latest Windows updates and disable Windows auto-update
Allow Remote Desktop connectivity

Set desktop visual effect to “best performance”

Set wallpaper to a single solid color

Set classic start menu (for applicable Microsoft Operating Systems)
Disable sound over Remote Desktop connection

Disable automatic sleep or hibernate mode
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Disable automatic power off for the display and hard disk
10. Disable the Internet Explorer enhanced security mode
11. Turn off screensaver

Exporting your VM from VMware

VMware Workstation instructions

Pre-requisite: You must change the setting of “VMware Tools Update” option to “manual”:



Right-click the virtual machine in Workstation and click Edit Settings. In the Options tab, change
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Step #1: Clone the snapshot you want to upload (the following steps may be different depending on
the version of VMware Workstation you are using):

To create a fully independent copy of a virtual machine from a snapshot, you must make a clone.
Note: The snapshot must be from a virtual machine that is powered off. You cannot make a clone from a

snapshot of a virtual machine that is powered on.

In VMware workstation, choose VM > Snapshot > Snapshot Manager
Select the snapshot to clone
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Click OK in the confirmation dialog box

Click Clone (There is an option to make linked clones or full clones. Please select full clone

Note: Ensure hardware compatibility is set correctly before exporting the image to OVA or OVF formats.

Hardware versions 4 through 9 are supported. You can change the hardware compatibility version

before exporting your image:
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Step #2 - Export this clone as an OVF or OVA file:


http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2036689

1. In VMware workstation, choose File -> Import or Export

(This will start a conversion wizard) - (e !
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4, Choose all disks and maintain size
Map or Disconnect Virtual Disks...

5. Destination Type = virtual appliance Add to Favorites
Exit

6. Create a name and choose a location
7. File Options = choose multiple files (*.ovf) or single file (*.ova)

VMware vSphere instructions

1. In VMware Virtual Center, choose File = Export = Export OVF Template...
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Multi-part Zip Archive

CloudShare supports VM Upload with multi-part zip archive using the open-source application 7-zip. This
method splits the large OVF or OVA packages into many smaller parts which results in a faster and more
efficient upload transfer. In addition, when a corruption or failure is reported, you will only need to re-
upload the affected zip file(s).

The process to create the multi-part zip files on an OVA package is as follows:

e Install the open-source application 7-zip (http://www.7-zip.org/download.html)

e Right click on your exported OVA file

e Select 7-zip and “Add to Archive...”

e Do not change the default Archive name

e For Archive format, select zip

e For Compression level, select Store or Fastest (since VMDK files do not compress well)

e Define the file size in Split to volumes, bytes (the largest recommended file size is 1GB or
1024MB)

e Click on the OK button

The process to create the multi-part zip file on an OVF package is the same as above with the exception
that its VMDK file will be split into many zip files. The OVF descriptor file (*.ovf) and full set of zip files
generated from the VMDK will need to be uploaded.

r — o
Add to Archive =5
Archive:
Clone of Windows & x&4.zip - D
A mETEE 2ip - Update mode:
[.F\dd and replace files ']
Options
Compression method: Deflate i Create SFX archive
Dictionary size: [ Compress shared files
Solid Block size: FErrE
Number of CPU threads: & -] /4
Reenter password:
Memory usage for Compressing: 131 MB
Memory usage for Decompressing 2 MB | Show Password
| WSplt to volumes, bytes: Encryption method: ZipCrypto n
250M| -

Parameters:
oK [ Cancel ][ Help

L — ———

Optional: It is highly recommended that you generate an MD5 file that will allow CloudShare to ensure
the integrity of your uploaded VM:


http://www.7-zip.org/download.html
http://www.7-zip.org/download.html

e The MDS5 file name must have the same prefix of the OVF or OVA file used to generate the
multi-part zip files followed by a .md5 extension
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|| Clone of Windows & x64.md5S

(1 Clone of Windows & %64 zip 001
|| Clene of Windows & x64.zip.002
|| Clone of Windows & x64 .zip.003

e Use MD5sums command line tool (download from http://www.pc-tools.net/win32/md5sums/)

with the -u flag for UNIX compatibility to generate a hash for each of the zip files. Alternatively,
you can use Linux tool md5sum as described here (link to
https://help.ubuntu.com/community/HowToMD5SUM)

e Each line in the MDS5 file should have the MD5 hash followed by the zip file name. Text file
sample:
5 Clone of Windows x64md5 |

Sp00ae64b8d51lcdeld4c34196a956571f *Clone of Windows
af4£7474df5725d9c40e596e1f48a88a *Clone of Windows
843e8f3d6%aZzbe076fde2913c6857%a *Clone of Windows
fic2elal8334ecelacidibbedilci4be7? *Clone of Windows
bT72826a12b7b2leZ6a0e55cl46b3Tf4c *Clone of Windows
ab7la34acdecTod3cblbibelc99%ec4kh *Clone of Windows
1b9432231c092c2b3aBdede8T6efdbeld *Clone of Windows
8 39al17c03680balel0l194d078cfd992e2 *Clone of Windows
S bfib3e8T7e3d6015d05af8ll4ab26albté *Clone of Windows
10 f6c2167al1433Tel3if30acl6eaZ3ifb087 *Clone of Windows
11 07bS950a5456cl24939d9369c02e3d233 *Clone of Windows
12 chbae’26dfce25e8024c6a4d22d4f2b3 *Clone of Windows
13 a58T7bce43d9d90d456958053231df2209 *Clone of Windows
4  44e4caff4b0d045fed6Tcfib3a4f35bf2 *Clone of Windows
< 8c3ecelfcTb34676d1177Thaad447fc8cf *Clone of Windows
16 8c33B8e2l8%edB89%6cbBacta3fc40322b43 *Clone of Windows

X64.zip.001
®x64.zip.002
Xx64.zip.003
X64.zip.004
xX64.zip.005
Xe4.zip.006
x64.zip.007
X64.zip.008
.zip.009
Xx64.zip.010
X64.zip.011
x64.zip.012
X64.zip.013
x64.zip.014
X64.zip.015
®x64.zip.016
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o If an MD?5 file was generated, it too must be uploaded to the Cloud Folders directory that
contains the OVF or OVA

o Upload the ovf file (.ovf) plus the full set of zip files of the OVF directory (note that the OVF zip
files must reside in the same directory as the .ovf file), or the OVA file to your CloudShare Cloud
Folder via FTP

Step #1 - Uploading your VM to your “Personal” CloudFolder

Prepare the Transfer

You will now validate and prepare to transfer the VM to your personal Cloud Folder. To find your Cloud
Folder details, login to your CloudShare account and browse to the “Cloud Folders” tab:


http://www.pc-tools.net/win32/md5sums/
https://help.ubuntu.com/community/HowToMD5SUM
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Cloud Folders

How do | use Cloud Folders?

FTP/FTPS Information:

Host: folders.cloudshare.com
User: robert+yoyodyne@cloudshare.com
Password: UMBEMey60F55(regansrate)

ftp://robert¥%2byoyodyne®4ecloudshare.com: UMBEMey60f55@folders. cloudshare. com/

Yoyodyne Propulsion Systems's Cloud Folder (8b0d1a) You are using 0.00GE {0%) out of 1024GE available
Yoyodyne University's Cloud Folder (cfe3dc) You are using 0.00GE {0%) out of 1024GE available
Yoyodyne Shared Environment’s Cloud Folder (e880fa) You are using 0.00GE (0%) out of 1024GE available

EET cloud Folders also support FTPS

FTP Client Settings

Perform the following changes to your FTP Client application before starting the transfer:

e  When configuring your FTP client of choice, make sure to use FTP passive connection mode

e Upload image using binary mode and don’t forget to switch to ASCII (text files) or Automatic
after image transfer completes.

e Make sure that you transfer the VM images to your personal Cloud Folder. Some projects may
have multiple Project Folders, use caution to select the correct destination folder.

e By default, you will have 30GB of disk space for your personal Cloud Folder. If you need more
disk space, please contact support@cloudshare.com

Since the upload takes a long time, it is recommended that you validate that your VM format is
supported by using our OVF validation tool (see image) before starting the upload process:


mailto:support@cloudshare.com

Cloud Folders

How do | use Cloud Folders?

FTPIFTPS Information:

Host: folders.cloudshare.com
User: johni@acme.com
Password: abcdefghl23(regenerate)

ftp://johnk4@acme.com:abcdefgh123@folders. cloudshare.com/

Gil Tayar's Cloud Folder (7994f0) You are using 0.00GE (0%) out of 30GE available

Cloud Folders also support FTPS

Upload your own virtual machine v
To upload your VM, follow these steps:

o Read the instructions (important!)

o Validate your virtual machine compliancy »

o Upload to your Cloud Folder by using the above FTP Information

o Select and add your machine using the CloudFolders browser [E

Once your VM was validated successfully, you can start uploading your VM using the FTP client of your
choice using the information shown on your Cloud Folders tab. However, we do recommend that you
split the files into multi-part zip archive before proceeding with upload.

Step #2 - Importing your VM

There are 2 options to import the VM you have uploaded:

e Import to an existing environment
e Import to a new environment

When using an existing environment, you should first launch the environment and open the
Environment details page. From this page, select Edit=> Add VM

Alternatively, when creating a new environment you will land on the Add VM when you click the Create
Environment button
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The next page enables you to add a VM from your Cloud Folder “My Uploads” tab.

Select the VM files (either OVF or OVA files) to import. Then click the Validate machine button.

Create environment

[F— Windows & x64 % | Environment Resources
(==Y h
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You will then need to provide the following required information, and then click the Add VM button

VM name

Description
Administrator user name
Administrator Password
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Operating system family (Windows or Linux)

This process of adding a VM can be repeated multiple times within any environment. You have the
option of selecting VMs from any of the tabs shown above. Once you have added the VMs you
require, click the Save changes button.

The CloudShare application will validate that the VM is using a supported format and if all validations
pass, the import process will start.

* Note: Since the import process might take a long time (up to a few hours), you are requested to
extend the environment so it will have at least 5 hours of remaining time until its expiration,
otherwise the environment might be deleted and the import process will be aborted.

Once the import process has completed, an e-mail will be sent to your e-mail address as configured in
your CloudShare’s account (your CloudShare account name).

If this step was successful, you are ready for the last step — Configuring your VM.

Step #3 - Configuring your VM Networking and Access

Since your VM was originally running outside of CloudShare, it will require a few configuration changes
in order to operate correctly in its new environment.



Networking configuration

When importing your VM into CloudShare service, its network
adapters are initially disconnected. You will need to configure the
networking by navigating to the Environment Details page and then |:o Add VM
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You will see the CloudShare network configuration tool.

Edit Networks

To configure the VM networking,

Advanced Mode

follow these steps: o oms0[=] o (Q) 20 rwrt
1. Click on the relevant VM or centos & Server xee
choose a node from the drop v
down menu —=
2. Select the “more details” link TN o o
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configure B " i
3. Select the relevant Network @ raa st |
the VM should be connected e 8
to |

4. Configure the IP the machine will have — this IP should be on the relevant network

5. Use the Save Changes button to save these changes

6. Connect to the VM using console access to configure the IP, default gateway and DNS settings
on the VM itself. The default gateway IP will be the first IP in the subnet - xxx.xxx.xxx.1
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You were asked to enter the administrator credentials in step #2. / -
(@) Addvm
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/ ) .
IHG Edit domains
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To resolve this, select the environment Edit button - Edit users & access and update the credentials to
match those configured in your machine:

Saving your work

IMPORTANT: In order to save your work you need to take a snapshot.
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Once you have a snapshot of the environment, you can then use "JG' re Smamenon ‘
. \! arKe =napsno
CloudShare’s features to create and share environments. You can also \

copy your environments and customize each environment based on

our requirements. ) 1
y q It:@' Extend Environment ‘

You will be able to use the uploaded VM files, importing them to other
environments.

CloudShare continuously adds functionality to its service but we are especially proud of the VM upload
feature and are sure you will enjoy the benefits that it provides.



